Announcement

Collapse
No announcement yet.

Minikin v2 - Stuck on "Download Mode"

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Minikin v2 - Stuck on "Download Mode"

    To the team at Asmodus,

    I purchased an Asmodus Minikin v2 from an approved UK seller in November 2016 and it’s been my workhorse mod ever since - a truly brilliant bit of kit if ever there was one!

    However, when swapping out the batteries yesterday, I noticed with some alarm that the dreaded “Download Mode” message was displayed on-screen when I powered it on, and no matter what, it won’t go away now!

    Based on this, I was wondering if the warranty would cover any repair or replacement as I am very keen to have a working Minikin in my life, hence my getting in touch.

    I will very much look forward to hearing from you with your thoughts.

  • #2
    Have you tried to flash firmware?
    go through standart flashing procedure, it could help.

    Comment


    • #3
      Originally posted by un_false View Post
      Have you tried to flash firmware?
      Thanks for the reply to my initial post here, un_false!

      When I first noticed the issue, the first thing I did was reflash the Minikin in the hope that this might help fix it, but sadly, even having done that the problem still remains

      Comment

      Working...
      X